Announcement

Collapse
No announcement yet.

Vss Vintorez Not Firing, No air from Nozzle, Gearbox sounds weird

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Vss Vintorez Not Firing, No air from Nozzle, Gearbox sounds weird

    Forcecore/S&t vss was firing fine tge other day, then it stopped working, bb's spit out of barrel then drop.

    Hop up rubber was torn so thought that may be the issue but I checked the air nozzle and nothing is coming out it just moves back and forward.

    Also the gearbox makes a weird noise, like metal hitting metal.

    Haven't opened the gearbox up yet as I don't have a clue what I'm doing.

    Put a video on youtube so you can hear the noise.

    Thanks for help​ in advance.


  • #2

    Comment


    • #3
      Black ring snapped on gun and white end cap was detached from piston, this the issue?

      Comment


      • #4
        So your piston "0" ring is snapped and your piston head has come away , Yes these are your issues I would buy a new piston head set should only be cheap
        Please do not advertise on this forum

        Comment


        • #5
          Hello,

          I found the nut for the piston and had a flat o ring for it.

          Probably going to buy a nee piston head anyway, aslong as i can get one which fits as its just a screw in.

          ​​​​​​Got the gun working after doing that but it has an issue when firing.

          Think i have messed up the selector switch, fires every second pull in semi, no full cycle sometimes then cuts off completely, auto works then sometimes moves the lever to either semi or safe, fires bbs then doesn't then does, and sometimes they roll out the barrel.

          Not sure how to properly align it, took a good while to take it apart aswell.

          Cheers.

          Comment


          • #6
            I would replace the piston head tbh and look for any damage inside the cylinder.
            Its a v3 gearbox and it sounds like you didnt get the trigger assembly back together correct ( v3's can be a pain for 1st time gearbox's ) or the contacts have been pushed open too far
            Please do not advertise on this forum

            Comment


            • #7
              Re aligned the selector plate spot on this time, however found out that anti reversal latch was in ghr the wrong place and one of the teeth is missing on my gears.

              Got it firing okay although putting it on auto I have to switch to safe then down.

              Which head would fit my piston?

              Cheers.

              Comment


              • #8
                hmm year that need ripping out mate , send me your address will wing you another gear ( little worse for ware atm but will try and match it :P )
                Please do not advertise on this forum

                Comment

                Working...
                X